fascinated with tofu

豆腐に魅せられて

DS-Lite 設定における IPv6 セキュリティ

DS-Lite では家のネットワークに2つのレイヤが存在する。ひとつめは IPv4 のレイヤで家のブロードバンドルータは Layer3 デバイスとして機能する。ふたつめは IPv6 のレイヤで、ブロードバンドルータは Layer2 デバイスとなる。

f:id:rrringress:20210214211134p:plain
https://www.mfeed.ad.jp/transix/staticip/

IPv4 のレイヤではセキュリティの観点でルータ側で追加で実施すべきことは特になさそうだが、IPv6 では家庭内の IPv6 アドレスはいわゆる グローバルアドレス であり、IPv6 インターネットの方からも丸見えな状態だ。もし会社などに VPN 接続ができる環境をお持ちの方や、携帯電話のテザリングができる人はその状態から家庭の端末の IPv6 アドレスに対して ping, ping6 を実行してみてほしい。実行できない人はこちらのサイトがわかりやすい。

VNE 提供の設定例だとセキュリティやアクセス制御関連の設定まではカバーされていないケースが多いが、Yamaha RTX および SEIL では IPv6 利用時のセキュリティ設定についての言及があった。セキュリティ設定においてはコントロールプレーンでのアクセス制御と、データプレーンでのアクセス制御それぞれ考える必要があるが、上記の設定例はいずれもデータプレーン、つまりルータ配下の IPv6 端末を保護するためのアクセス制御設定が書かれている。コントロールプレーン保護については例えばルータの管理インターフェイスの保護などをさすが、例えばルータの telnet, ssh, http, snmp, dns などが見えていないかといった観点でチェックをすれば良さそう。nmap が使えるなら nmap -6 などもよさそう。設定場所は line vty の ACL など。

データプレーンでの Cisco ルータでの設定例は正直よい参考例がなかった。ポイントとしては Neighbor Discovery(ND : 近隣探索; IPv4 における ARP 解決のような MAC アドレスのマッピング)で必要な icmpv6 プロトコルの許可と、ZBFW の設定を組み合わせた設定を入れるのがよさそう。

参照

y2blog » IPv6(IPoE)のセキュリティ対策

フレッツ光ネクスト インターネット(IPv6 IPoE)接続

IPsecを使用したVPN拠点間接続(IPv6 IPoE) : コマンド設定

IPv6のセキュリティを強化する

IPv6 Implementation Guide, Cisco IOS Release 15.2M&T - Implementing Traffic Filters and Firewalls for IPv6 Security [Cisco IOS 15.2M&T] - Cisco

徹底解説 v6プラス | 日本ネットワークイネイブラー株式会社

IIJmio 光 DS-Lite 設定例【Cisco】【ひかり電話なし】

はじめに

Softbank 光から IIJmio 光に事業者変更した。1月末に SB に電話して、2月1週目に PPPoE の切り換え、その数日後に IPoE の切り換えが完了した。

DS-Lite は Dual-Stack Lite の略で、かんたんに言うと IPv6IPv4 を両立するネットワーク構成を、ご家庭の一般的なルータに実装されている機能の組み合わせで実現する技術だ。実際には家の中の端末は IPv4 さえ喋れればOK。詳しく知りたい人はこちら

SEIL、Yamaha、Ubiquiti、Buffalo はかなり充実しているが、Cisco ルータについてはサンプルコンフィグが圧倒的に足りてないため書いておきたい。一番参考にしたのは Internet Multifeed の隠れているページだ。

設定

Disclaimer

C891FJ version 15.4 使用
ゼロから入れたコンフィグではない点ご留意ください

IPv6 有効化

ipv6 unicast-routing
ipv6 cef

ブリッジ有効化

bridge irb

GRE トンネル

interface Tunnel0
ip address 192.0.0.2 255.255.255.248 <<< RFC で決まってる
tunnel source BVI1
tunnel mode ipv6
tunnel destination 2404:8E00::FEED:101 <<< NTT 東と西で違う
bridge-group 1

WAN I/F

interface GigabitEthernet8
no ip address
duplex auto
speed auto
media-type rj45
bridge-group 1

BVI I/F

interface BVI1
ip address 192.168.0.1 255.255.255.0 <<< LAN 側のデフォゲ
ipv6 address autoconfig default
ipv6 enable

デフォルトルート

ip route 0.0.0.0 0.0.0.0 Tunnel0

LAN 向けの DHCP Server

ip dhcp pool DHCP
network 192.168.0.0 255.255.255.0
dns-server 8.8.8.8 <<< いらないかも
default-router 192.168.0.1

確認

router#sho ipv6 interface bvi1
BVI1 is up, line protocol is up
  IPv6 is enabled,
(snip)
  Global unicast address(es):
    2409:10:XXXXXX, subnet is 2409:10:XXXXXX <<< Internet Multifeed の IPv6 Prefix を確認  
(snip)
  Hosts use stateless autoconfig for addresses.
router#ping www.iij.ad.jp
Translating "www.iij.ad.jp"...domain server (2404:1A8:7F01:B::3) [OK]

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:240:BB81::10:1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/4/12 ms

所感

PPPoE の場合と比べて NAT の設定が不要な反面、ポート開放ができないので不自由を感じることがあるかもしれない。 ONU とルータの間にハブをかませることで PPPoE を併用している例などがあったが SVI などで代用できないだろうか。

速度は正直 Softbank 光の IPoE のほうが速かったかもしれない。混み合う日中も 200 Mbps 上り下り出ていれば御の字。

参照

https://www.mfeed.ad.jp/transix/dslite/cisco_1812j.html
https://www.mfeed.ad.jp/transix/dslite/cisco_1111-4p.html
https://blog.kit-a.net/2018/02/23/iij-mio光-ipoe-でipv6-ipv4-環境を作ってみた-cisco-841m-dhcp-ra環境-ds-lite/
https://uchy-13.hatenablog.com/entry/2017/05/07/201459

【GarageBand】【SYNCROOM】 VST 設定メモ

tl;dr

2chインプットできるオーディオインターフェイスで、ライン入力ー①、マイク入力ー②、MIDI キーボード入力ー③を Syncroom に渡す設定のメモ

・お手持ちの MIDIバイスGarageBand で認識できている状態(本稿では割愛)

・環境設定でオーディオインターフェイス (mac なので USB AUDIO CODEC) を出力デバイスと入力デバイスに設定

・トラックを合計3つ作成し、①、②はオーディオを選択、③はソフトウェア音源を選択

・お手持ちのオーディオインターフェイスの Channel と併せた入力をトラックごとに選ぶ

・全てのトラックで 録音可能 を ON にする。オーディオトラックは モニタリング も ON にする (重要)

・マスタートラックのプラグインAutio Units > Yamaha > syncroom_au_bridge を追加(Syncroom インストーラに含まれていたプラグイン/ライブラリ/Audio/Plug-Ins/Components にコピー済み)

設定のスクリーンキャプチャ

f:id:rrringress:20210201220428p:plain
環境設定

f:id:rrringress:20210201220754p:plain
Track

f:id:rrringress:20210201215651p:plain
INPUT ①

f:id:rrringress:20210201215723p:plain
INPUT ②

f:id:rrringress:20210201215942p:plain
録音ボタン
↑録音ボタンは押すと赤くなります。上画像だと Alto Sax だけが赤いですが、最終的には line, mic も押すので赤くなります。

*ボタンの表示が少ない場合、右クリックでトラックヘッダの編集をします。

f:id:rrringress:20210201220024p:plain
Track Header
f:id:rrringress:20210201220104p:plain
Track Header

f:id:rrringress:20210201221359p:plain
Yamaha AU Plugin

f:id:rrringress:20210201215820p:plain
Master Output

参照

싱크룸(SYNCROOM) VST모드 설정하기 (악기소리 & 말소리 모두 입력하는 방법)

Mac 上の他社製 Audio Units プラグインのインストール先 - Apple サポート

注釈

GarageBandプラグインVST ではなく AU なんですが、SYNCROOM 側は VST 連携というのでそちらに合わせました。

サイレントブラスで宅録および SYNCROOM するためのセッティングメモ

何の話

YAMAHA サイレントブラスで管楽器の音をパソコンで録音したり、オンラインでジャムセッションするときの配線などのメモ。

セッティング

この通りにつなぐとよい。 f:id:rrringress:20210117192500p:plain

注意点

・PC(Mac OS X および Windows 10)から AGM02 はオーディオ IN/OUT ともに「USB AUDIO CODEC」という名前のデバイス名で見える。ドライバーなどのインストールは不要。(というか用意されていない。買うまで知らなかったけど Windows の人は ASIO ドライバーがメーカーで用意されているやつが本当はお勧め)

・AGM02 とヤマハプリアンプ(STX-2)の間のケーブルは自前で用意する必要がある。3.5mm ステレオピンプラグ <-> ステレオ標準プラグ 変換ケーブル (曽根さんの動画によるとモノラル標準でもよいらしい) で接続する。

・AGM02 で、Monitor Headset を利用する際、PC からの音も同じイヤホンで返したい場合 USB Playback ボタンを ON にする。(PC で流れている音源は SYNCROOM には入らない)

・さらに、PC で流している音源を SYNCROOM に入力したい場合、PC 側でマイク(入力)デバイスを AGM02 に指定する(いわゆるループバック機能)。MAIN MIX側にイヤホンやスピーカーをつなぐと音源と自分のライン入力がまざったものを返しとして聴くことができる。

Windows の場合 WASAPI でやってます。ASIO4ALL は私の Windows10 では AGM02 で音が出ませんでした。

参考にした動画

ほぼこの通りにやりました。「サイレントブラス 宅録」などと検索しても機材のセッティングや配線について説明された記事が見つからなかったためこれを書きました。

エフェクターも試してみたいです。

www.youtube.com

www.youtube.com

www.youtube.com

必要なもの

サイレントブラス

ヤマハ YAMAHA サイレントブラス トランペット・コルネット用 SB7X

オーディオインターフェイス

・曽根さんが使用しているもの
ヤマハ YAMAHA ウェブキャスティングミキサー オーディオインターフェース 3チャンネル AG03
田中充さんが使用しているもの
Steinberg スタインバーグ USB2.0 24bit/192kHz オーディオインターフェース UR12
・私が使用しているもの
ammoon ミニ2チャンネルサウンドカードミキシングコンソールデジタルオーディオミキサー2バンドEQ内蔵48Vファンタム電源5VUSB電源付き

ケーブル

・曽根さんが紹介している標準3.5mmケーブル
オーディオ変換ケーブル 3.5mm ステレオミニプラグ(オス) - 6.3mm モノラル標準プラグ(オス) 1m VM-MS3-1m

・こういう変換アダプタがあれば3.5mmミニプラグのケーブルがあれば上の変換ケーブル不要
ステレオミニプラグ (メス) ⇒ ステレオ標準プラグ (オス) 3.5mm ⇒ 6.35mm 変換アダプタ

以上

Ammoon AGM02 の使い方メモ

はじめに

Ammoon のオーディオインターフェイス を Aliexpress で買ってみた。
マニュアルはあるが手探りな部分も多かったので、自分の用途にあいそうなセッティングのメモを残しておきたい。
あとはじめて Aliexpress 利用したのでその記録もあわせて記載する。

想定用途

1.サイレントブラスの PHONES 端子を標準 1/4 プラグに変換して CH2 INPUT に挿して、Garage Band など PC の DAW ソフトウェアに入力する *こういうやつを使う
2.ウェブ会議のマイクとイヤホンを接続して手元で音量調節する

設定メモ

マニュアルの PDF 版はここの Spec のタブにある
https://www.ammoon.com/p-i3974.html

f:id:rrringress:20200605171510p:plain

USB Playback ボタン(上図の9番)

押してない状態

一言でいうとループバックモード
と、知ったように書いているが昨日までループバックの概念がまったく理解できていなかったが、以下ブログを読んで勉強させていただきました。イラストがわかりよい randrandr.blog.fc2.com

I/F 状態
MAIN MIX 出力あり(クリアにきこえる)
MONITOR 出力なし
USB AUDIO CODEC 出力あり(パソコンのマイクに INPUT されている)

MAIN MIX = RCA 端子のインターフェイス(2)
MONITOR = 右上のヘッドセットマークのインターフェイス(4)
USB AUDIO CODEC = PC と接続したときのオーディオデバイス名(あえていうと3)

●所感
・マイナスワンと一緒に演奏して重ねた状態を録音したいときに便利
・とはいえ DAW で複数トラックを分離して扱えるので、あえてオーディオインターフェイスで重ねる必要性はない
・ちなみにこのモードであればウェブ会議や Youtube など PC 内で再生されている音を Input にルーティングできるので、BGM 付きで配信したり、Google Document で自動文字書き起こしなどができる

押している状態

PC の音源とは重ね取りしないシンプルなモード

I/F 状態
MAIN MIX 出力なし
MONITOR 出力あり(ツマミ3時をすぎるとややホワイトノイズあり)
USB AUDIO CODEC 出力なし

●所感
・PC のマイナスワン音源にあわせて演奏するときに便利
・基本はこっちのモードで使うほうが多そう
・MONITOR のつまみで自分への返しを調節できる
・MAIN/MIX のつまみは(当然)関係ない
YAMAHA サイレントブラスのプリアンプの AUX IN に接続した音源もミックス可能

CH2 INPUT の GAIN (5)

HIGH にするとすぐにホワイトノイズもしくは音割れが発生した
LOW にした状態で、下のつまみ MAX および MAIN MIX のつまみMAXでまあまあな音量で録れる

CH2 INPUT のギターマークボタン(6)

押しても変わらない (このボタンの存在理由ご存じの方教えて下さい)
MIC/LINE のままでよいことにする

GUITAR switch: For switching (on/off) the input impedance on channel 2. Press down (on) when directly connecting an instrument with high output impedance, such as an electric guitar or electric bass to channel 2. When this switch is turned on, use an unbalanced cable with phone plugs to connect the instrument to the mixer. The mixer will not operate correctly if a balanced cable is used.

満足度

DAC/ADC 類は初めて購入したので比較はできないが、モニターモードでホワイトノイズが乗る以外は特に気になる点なし。
見た目も品質もなかなかよいんではないだろうか。
あと実は楽器のベルにつけるコンデンサマイクも繋げられるようになったので CH1 の Phantom 電源も活用できそうな気がする。

購入経緯

日付 経緯
3/30 YAMAHA サイレントブラスを購入して感動
4月某日 複数の友人らからオーディオインターフェイスの話を聞き、宅録やウェブ会議でも便利と知る
4/22 サウンドハウスYAMAHA AG03 をポチる*
4/28 サウンドハウスに納期問い合わせ
5/3 在庫なし&納期未定と判明
5/4 せっかくなので Aliexpress で似たようなスペックのものをポチる
6/2 Ammoon 家に届く

*サウンドハウスでポチった段階でオーディオインターフェース類がのきなみ品薄ということを意識しておらず、納期未定でもしばらくすれば届くかなと楽観的に決めてしまったというのが失敗だった。

Aliexpress を利用した背景は、Amazon よりも2−3000円安く、納期がそこまで変わらなかったため。実際まるまる一ヶ月かかっているのでなんとも言えないが世界的にも混乱期であったので届いただけでも嬉しい。

Aliexpress での購入エクスペリエンス

初めての利用だったのでロストしたりしても保証が手厚そうな Ammoon Official Store から購入した。 (6/5 現在品切れ) www.aliexpress.com

●利用者視点での気づき
・同じ製品がいろいろなストアでそれぞれの値段で売られている
・納期はだいたい13-20日と記載されている
・基本送料無料
orders という指標が最近売れた数で、人気があるかどうか判断できる
・売り手と直接メッセージしやすい
・結果論だが、配送ステータスは基本一週間遅れくらいで反映されていたので、更新されていなくても徐々に近づいている可能性がある(下図参照)

f:id:rrringress:20200605153323p:plain
Order Tracking

忘れた頃に届くのが逆に楽しいので、自転車グッズやオーディオ小物などぽちぽち買っていきたい。 真贋わからない製品が予想できない納期で届くということで自分の中にカーゴ信仰に似た何かが芽生えている予感がする

Github pages のカスタムドメインを Dozens から Cloudflare に無料移行

はじめに

いままで Github Pages をカスタムドメインにするために無料で使っていた DNS サービス Dozens が終了するため、Cloudflare を使って移行してみました。10月31日なんてもうすぐですね。

参照 全サービス終了のお知らせ | DNSを自由に簡単に。Dozens(ダズンズ)

サービス終了までのスケジュール

・2019年3月1日(金)

新規会員登録・有料プランへのアップグレード受付終了

・2019年9月30日(月)

コントロールパネル・APIの停止

・2019年10月31日(木)

DNSサーバーの停止・サービスの完全終了

続きを読む

家のインターネットの回線速度を speedtest-cli で観測する

はじめに

集合住宅のインターネットは利用者が少ない昼間は比較的すいていて、夜間は混雑していることが多いらしい。 インターネットが遅いなと感じたときにみんながよく使っている speedtestコマンドラインツール版があると知り、定期実行して観測してみました。

続きを読む